Rails bundler: “Could not find tilt-1.3.5 in any of the sources”

I have never encountered this problem before so I really don’t know where to start looking for answers… despite Google ofcourse which seems to be an empty road concerning this topic.

When I try to push my application to heroku I get this message:

-----> Ruby/Rails app detected
-----> Installing dependencies using Bundler version 1.3.0.pre.5
       Running: bundle install --without development:test --path vendor/bundle --binstubs vendor/bundle/bin --deployment
       Fetching gem metadata from https://rubygems.org/.........
       Fetching gem metadata from https://rubygems.org/..
       Could not find tilt-1.3.5 in any of the sources
 !
 !     Failed to install gems via Bundler.
 !
 !     Heroku push rejected, failed to compile Ruby/rails app

I have destroyed my gemset and started over numerous amounts of times, as well as flat-out required tilt in my Gemfile, but no luck, I still get this message.

Like I said, I have never got this error until yesterday and assumed it was a minor bug that would be fixed. Seems as if that isn’t the case, and I am scratching my head trying to figure out what needs to be done to fix this issue.

Any suggestions?

EDIT GEMFILE

source 'https://rubygems.org/'

gem 'rails', '3.2.12'
gem 'thin'
gem 'bcrypt-ruby', '~> 3.0.0'
gem 'bootstrap-sass'
gem 'will_paginate'
gem 'bootstrap-will_paginate'
gem 'jquery-rails'
gem 'rails_autolink'

group :assets do
  gem 'sass-rails', '~> 3.2.3'
  gem 'coffee-rails', '~> 3.2.1'
  gem 'uglifier', '>= 1.0.3'
end

group :development, :test do
  gem 'sqlite3'
end

group :production do
  gem 'pg', '0.14.1'
end

  • Upgrading rubygems not working
  • Install gems in parallel (faster)
  • Updating content on the fly in Rails
  • Bundler: Allow user added gems in an UserGemfile
  • How do I wrap up a Ruby C extension in a Ruby Gem?
  • “TypeError: can't dup NilClass” in Capybara + selenium driver
  • Get value from dropdown in div
  • require 'ruby-debug' LoadError: symbol not found
  • 3 Solutions collect form web for “Rails bundler: “Could not find tilt-1.3.5 in any of the sources””

    I am getting the same error. As iRichLau noted in this comment, locking to 1.3.4 or 1.3.6 works.

    In Gemfile:

    gem 'tilt', '1.3.4' # or '1.3.6' is now out and also works.
    

    Then bundle:

    bundle update tilt
    

    Make sure the commit message is commensurate with the ridiculousness of this phantasmal error. 😉

    running bundle update and then git add before pushing should fix it

    This happened to me when I had 2 different version of the brightbox gem.

    The newer brightbox gem requires a newer version of bundle.

    So in the top of my deploy.rb I forced the brightbox gem version to be:

    gem 'brightbox', '2.3.8'
    
    Ruby is the best programming language in the world - Ruby on Rails.