Tag: heroku

Autoloading ruby gem warning, may be causing Heroku application error?

I have a very simple Ruby Serve prototype website, which works fine locally but doesn’t work on Heroku: Aug 02 12:35:40 localp app/web.1: [2013-08-02 11:35:40] INFO WEBrick 1.3.1 Aug 02 12:35:40 localp app/web.1: [2013-08-02 11:35:40] INFO ruby 1.9.3 (2013-06-27) [x86_64-linux] Aug 02 12:35:40 localp app/web.1: [2013-08-02 11:35:40] INFO WEBrick::HTTPServer#start: pid=2 port=4000 Aug 02 12:36:39 localp […]

Installing gems issues – doesn't work and then all of a sudden works?

I tried installing the heroku gem yesterday with “gem install heroku” and got the error message: ERROR: Could not find a valid gem ‘heroku’ (>= 0) in any repository. I just tried for the heck of it to install it today and all of a sudden it worked. This happened when I tried installing Git […]

Rails Admin help

I was pushing to heroku and everything seemed to be going fine until i went to the url. I get this error at the url: Application Error An error occurred in the application and your page could not be served. Please try again in a few moments. If you are the application owner, check your […]

differnces between gem file on local & heroku

I’m using the following gem in an app – https://github.com/dekart/facebooker2 It seems to be rendering different javascript on my local machine than when deployed to server – My local version looks like this – window.fbAsyncInit = function() { FB.init({ appId : ‘MYAPPID’, status : true, // check login status cookie : true, // enable cookies […]

Downloading xls file from application

I am using spreadsheet gem to generate a xls file in my applications public folder and then using the send_file method to send the file. My code worked properly on my local machine in test as well as production mode. But when I deployed this code on heroku it showed the following error: Permission denied […]

Error running heroku console. can't update heroku

When I try to run heroku console I get the following error: user@omnipresent:~/rails/demo$ heroku console ! This version of the heroku gem has been deprecated. ! Please update it by running: gem update heroku When I do the update..it says there is nothing to update! user@omnipresent:~/rails/demo$ gem update heroku Updating installed gems Nothing to update […]

Heroku rake db:migrate fails, undefined method in uninstalled gem

I am trying to get my application on Heroku, but when I run heroku rake db:migrate I get the following errors. It seems like the event_calendar gem is causing the problem, but the thing is, I’ve uninstalled it. There is no reference to it in the gemfile, or gemfile.lock, and it doesn’t show up in […]

Deploying Spree to Heroku

To deploy spree to heroku , I followed the guidline in https://github.com/krozen20/Spree-version-0.11.0/blob/master/spree.txt when typing “git push heroku master” it shows me this message Installing gem chronic 0.2.3 from http://rubygems.org ERROR: Error installing chronic: hoe requires RubyGems version >= 1.4. Try ‘gem update –system’ to update RubyGems itself. ! Heroku push rejected, failed to install gem […]

heroku, thin rack 1.1.0, gemfile requires rack 1.0.1

My ror app runs on rails 2.3.5(which requires rack 1.0.1), thin on heroku activates rack 1.1.0 by default and throws error: ” You have already activated rack 1.1.0, but your Gemfile requires rack 1.0.1. Consider using bundle exec.” my Gemfile: source ‘http://rubygems.org’ group :test, :development do gem “rack”,”1.0.1″ end gem “rails”,”2.3.5″ gem “mysql” gem “rake”, […]

installing i18n_routing on heroku (i18n requires RubyGems version >= 1.3.6)

I try to deploy my first app on heroku. I’ve created a gem manifest file which include: i18n_routing –version ‘0.3.3’ When I push to heroku, all the gems are installed but i18n: —–> Installing gem i18n_routing 0.3.3 from http://rubygems.org ERROR: Error installing i18n_routing: i18n requires RubyGems version >= 1.3.6 How can I update RubyGems on […]

Ruby is the best programming language in the world - Ruby on Rails.