Tag: osx

Avoiding AppleScript through Ruby: rb-appscript or rubyosa?

Hello fellow Mac rubyists and AppleScript haters, For those of you that have experience with both rubyosa and rb-appscript, I’d like the hear the pros and cons of each, which one you decided to stick with, and which one you’d recommend for a totally non-AppleScript savvy ruby old-timer. Also, are there any other options that […]

How can I switch to ruby 1.9.3 installed using Homebrew?

I have installed ruby 1.9.3 using hombrew brew install ruby But default 1.8.7 is still used. How can I switch osx to use 1.9.3 as default ruby?

ERROR: Error installing mysql: ERROR: Failed to build gem native extension

I am a beginner in ruby. when I install MySQL in gem,I got a problem which confused me a long time. I install MySQL from brew, as you know the computer system is OSX 10.10. I have try all solution that can found in stackoverflow,but can’t solve it. such as: 1. Install xcode-tool 2. GEM […]

ResolvTimeout exception while adding a gem source

I am getting a ResolveTimeout exception while adding a gem source. What does that mean? Here’s the result of gem env: RubyGems Environment: – RUBYGEMS VERSION: 2.4.5 – RUBY VERSION: 2.2.2 (2015-04-13 patchlevel 95) [x86_64-darwin14] – INSTALLATION DIRECTORY: /usr/local/lib/ruby/gems/2.2.0 – RUBY EXECUTABLE: /usr/local/opt/ruby/bin/ruby – EXECUTABLE DIRECTORY: /usr/local/bin – SPEC CACHE DIRECTORY: /Users/NSDont/.gem/specs – SYSTEM CONFIGURATION […]

Error to install Nokogiri on OSX 10.9 Maverick?

I upgraded my OSX (Lion) to Mavericks and I can’t install Nokogiri for my projects. I already install XCode 5.0.1, Command Line Tools (using xcode-select –install), and already installed libxml2 from Homebrew and I am still having problems. The error is: Gem::Installer::ExtensionBuildError: ERROR: Failed to build gem native extension. /Users/ericcamalionte/.rvm/rubies/ruby-1.9.2-p320/bin/ruby extconf.rb checking for libxml/parser.h… *** […]

why my mac has installed gem

My mac is 10.9.1, and it has installed Xcode. when I open the shell and type “gem“, it present the info like RubyGems is a sophisticated package manager for Ruby. This is a basic help message containing pointers to more information. Usage: gem -h/–help gem -v/–version gem command [arguments…] [options…] so I think my mac […]

Mac user and getting WARNING: Nokogiri was built against LibXML version 2.7.8, but has dynamically loaded 2.7.3

I have done all kinds of research and tried many different things. I know this question has been answered many times, but none of the suggested solutions are working for me. After upgrading to Lion I am getting segmentation faults in Ruby. I’m fairly confident it’s Nokogiri. So I installed libxml2 via Homebrew. I ran […]

shell can't find my ruby gem/ node library

I want to interact with http app, so I find htty and http-console. I use gem install htty Or npm install http-console But my shell seems can’t these commands. So I need add to my PATH or something else? Edit: I am using OS X Lion and I have npm and gem,both packages are successfully […]

Can't install ‘ferret’ gem on Mac OS X Snow Leopard

I can’t install the ferret gem in my computer with: gem install ferret Here is the error: macbookpro:tehago davidpombarlourido$ sudo gem install ferret Password: Building native extensions. This could take a while… ERROR: Error installing ferret: ERROR: Failed to build gem native extension. /Users/davidpombarlourido/.rvm/rubies/ruby-1.9.2-p180/bin/ruby extconf.rb creating Makefile make gcc -I. -I/Users/davidpombarlourido/.rvm/rubies/ruby-1.9.2-p180/include/ruby-1.9.1/x86_64-darwin10.6.0 -I/Users/davidpombarlourido/.rvm/rubies/ruby-1.9.2-p180/include/ruby-1.9.1/ruby/backward -I/Users/davidpombarlourido/.rvm/rubies/ruby-1.9.2-p180/include/ruby-1.9.1 -I. -D_XOPEN_SOURCE […]

Installing SASS on Yosemite

I’m struggling with an error in my command line while trying to install SASS. I’m just following what SASS website recommend to type in the command line: sudo gem install sass and here is the error I got: My-MacBook-Pro:~ username$ gem install sass ERROR: Could not find a valid gem ‘sass’ (>= 0), here is […]

Ruby is the best programming language in the world - Ruby on Rails.